Crashing of model after about 1500 hours of simulating

All topics specific to modeling questions in Enterprise Dynamics
Post Reply
Rico de Bokx
Posts: 4
Joined: Friday 02 September, 2022 - 17:54

Crashing of model after about 1500 hours of simulating

Post by Rico de Bokx »

Hi everyone,

The problem that I am experiencing is as follows. I made the attached model in ED after a few iterations. The process that I am modeling is pretty slow so I wanted to model it so I could test different ways of setting up the process and see what might change in output and throughput. The model is based on the fact that it is the power pack of a train that comes in to be refurbished. Of this particular customer, there are only ever 9 power packs on site in total. I tried to regulate this by attaching a card at the beginning and detaching the card at the end again, by setting the number of cards released I can regulate the number of power packs in the system.
I am now running into the problem that after running the model for 1000 hours it starts to stutter and stop, and after around 1500 hours it just crashes. I can see that the model slows down at the splitter because it is very slow to send the different parts one by one to their stations. Do you guys know a way to maybe fix this or relieve this problem so I can run my model for a longer time?

Looking forward to your guy's thoughts!
Attachments
Sim no cards V3.2.mod
(110.11 KiB) Downloaded 17 times
LH V3.2 no relations.png
LH V3.2 no relations.png (67.42 KiB) Viewed 233 times
LH V3.2.png
LH V3.2.png (144.51 KiB) Viewed 233 times
User avatar
Gabe-Hein Dijkstra
Posts: 10
Joined: Friday 13 May, 2022 - 10:16

Re: Crashing of model after about 1500 hours of simulating

Post by Gabe-Hein Dijkstra »

Hi Rico,

The problem lies in the fact that the number of atoms in your model grows exponentially. Instead of placing atoms in atoms you could maybe store the relevant information in tables or labels. Each atom has its own table (see the Help for more information) but there also exists a table atom.

Hopefully this helps!

Gr. Gabe-Hein
Attachments
Graph_NrAtoms.JPG
Graph_NrAtoms.JPG (39.35 KiB) Viewed 227 times
Rico de Bokx
Posts: 4
Joined: Friday 02 September, 2022 - 17:54

Re: Crashing of model after about 1500 hours of simulating

Post by Rico de Bokx »

Thank you Gabe-Hein,

I am already using labels to store and get some information from the model however I am just using the atoms to dictate when they can be released. I don't prefer to do it this way... maybe there is a way to let a server tell the source when it can release a product? Then I don't have to let the 'cards' circle around and the exponential increase in atoms would be stopped right?

Gr. Rico
Rico de Bokx
Posts: 4
Joined: Friday 02 September, 2022 - 17:54

Re: Crashing of model after about 1500 hours of simulating

Post by Rico de Bokx »

I fixed the problem!

I didn't know about the lock and unlock flow control atoms. I used those to produce the same function as the 'cards' looping around. Thank you for your help!

Gr Rico
User avatar
Gabe-Hein Dijkstra
Posts: 10
Joined: Friday 13 May, 2022 - 10:16

Re: Crashing of model after about 1500 hours of simulating

Post by Gabe-Hein Dijkstra »

Hi Rico,

Great to hear! I was just typing a response to your previous message. ;)

Gr. Gabe-Hein
Post Reply