Help needed for multiserver query

All topics on coding 4Dscript in Enterprise Dynamics.
Post Reply
shio
Posts: 5
Joined: Thursday 17 June, 2021 - 10:25

Help needed for multiserver query

Post by shio »

I need help with writing a query for the multiserver. I want to write a query where the busses wait 5 min in the multiserver and also the difference between label depart time and current time.

The if statement I tried to write for the send to look a bit like this: if(Label([depart]-time,
but I don't know how to put the 5 min in (300 sec)
User avatar
Gabe-Hein Dijkstra
Posts: 10
Joined: Friday 13 May, 2022 - 10:16

Re: Help needed for multiserver query

Post by Gabe-Hein Dijkstra »

Hi Shio,

I would be cautious trying to set the cycletime on the 'send to'-statement. Most atoms (like the MultiService) provide the option to set the cycletime using the GUI. For more information you can look at the Help-entry of the MultiService. The help can be found in the ribbon.

Hopefully this helps!
shio
Posts: 5
Joined: Thursday 17 June, 2021 - 10:25

Re: Help needed for multiserver query

Post by shio »

Hi Gabe,

I've built this model. The idea is to create a simulation model with 6 platforms based on the preferred distribution in bus.xls
and determine the required size of the alighting location and of the buffer.
Attachments
Bus.xls
(205 KiB) Downloaded 31 times
opdr4busstation.mod
(154.63 KiB) Downloaded 32 times
User avatar
Gabe-Hein Dijkstra
Posts: 10
Joined: Friday 13 May, 2022 - 10:16

Re: Help needed for multiserver query

Post by Gabe-Hein Dijkstra »

Hi Shio,

It is important to know the distinction between the 'Cycletime' parameter and the 'Send to' parameter. The 'Cycletime' parameter indicates the time needed to process products/atoms. The 'Send to' parameter is used to determine the output channel through which the product/atom needs to be sent. The moment on which the product/atom is released is not influenced by the 'Send to' statement. A MultiService has both the 'Cycletime' and 'Send to' parameters. A queue has the 'Send to' parameter but not the 'Cycletime' parameter.

Furthermore, I suggest you take a look at the parameters needed in the function Label. This information can be found in the help.

Good luck!
Post Reply