Error Message when opening the simulation

All topics on the Atoms in any Enterprise Dynamics Library.
Post Reply
christian123456
Posts: 12
Joined: Tuesday 22 September, 2015 - 19:41

Error Message when opening the simulation

Post by christian123456 » Sunday 27 September, 2015 - 20:27

Hi,
I somehow get a weird error message. I save the simulation that works fine and does not have any problems. When I then open the simulation again I get the following error message:


1 Compile error: "Open_Machine2" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine2) (KernelFnc)
2 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor2'. (KernelFnc)
3 Compile error: "Open_Machine3" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine3) (KernelFnc)
4 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor3'. (KernelFnc)
5 Compile error: "Open_Machine4" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine4) (KernelFnc)
6 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor4'. (KernelFnc)
7 Compile error: "Open_Machine2" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine2) (KernelFnc)
8 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor2'. (KernelFnc)
9 Compile error: "Open_Machine3" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine3) (KernelFnc)
10 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor3'. (KernelFnc)
11 Compile error: "Open_Machine2" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine2) (KernelFnc)
12 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor2'. (KernelFnc)
13 Compile error: "Open_Machine3" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine3) (KernelFnc)
14 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor3'. (KernelFnc)
15 Compile error: "Open_Machine2" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine2) (KernelFnc)
16 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor2'. (KernelFnc)
17 Compile error: "Open_Machine3" is not a valid expression. Reference: Do(CloseInput(c),Open_Machine3) (KernelFnc)
18 Could not set expression to attribute 'EntryTrigger' on atom 'Conveyor3'. (KernelFnc)


The strange thing is - when I open for instance conveyor 2 and go to the programming code and just add or remove a space sign and close it afterwards the problem is fixed. Nothing is actually changed. The simulation then runs without any problems. It is also funny as the same programming is done to conveyor 1 but this does not cause any trouble. "OpenMachine2" and so on are inside the user event atoms.

Attached you will also find a screenshot of the simulation. Would be great if somebody has an idea.

Thanks for support. :)
Attachments
simulation screenshot.JPG
simulation screenshot.JPG (186.19 KiB) Viewed 2593 times

Bram de Vries
Posts: 60
Joined: Thursday 08 January, 2015 - 13:29

Re: Error Message when opening the simulation

Post by Bram de Vries » Monday 28 September, 2015 - 09:23

Hello Christian,

It sounds like an issue with the sequence of atoms in your model tree, but could you maybe provide me with your model? Then I can have a look to see if this is indeed the case.

christian123456
Posts: 12
Joined: Tuesday 22 September, 2015 - 19:41

Re: Error Message when opening the simulation

Post by christian123456 » Monday 28 September, 2015 - 15:55

Hi Bram,
I have now changed the order of the Atoms in the model tree and moved all user Events to the top. Now it works... :)

Thank you very much, again ;-)

Post Reply