No route found and Invalid goal location

All topics related to questions in Pedestrian Dynamics
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

No route found and Invalid goal location

Post by Ken8891 »

Hi, I need help in this. I get this error.

309 PD error 1005: No route found between start location
310 PD error 1002: invalid goal location for agent
311 PD error 1002: invalid goal location for agent
312 PD error 1002: invalid goal location for agent

Best regards
Kenneth
Bram de Vries
Posts: 60
Joined: Thursday 08 January, 2015 - 13:29

Re: No route found and Invalid goal location

Post by Bram de Vries »

Hi Kenneth,

This usually means that an Agent wants to go to a destination which is not walkable (it could be in an obstacle for example). Usually these errors give you the location of the point that cannot be reached (an x, y and possibly z coordinate). You can check where this location is using the Show Location button (found under the View tab).

Are you able to solve your problem this way? If not, is it possible for you to upload your model? Then we can take a look.

Kind regards,

Bram
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

Re: No route found and Invalid goal location

Post by Ken8891 »

Hi, I have manage to locate which agent. But I don't understand why it is an invalid goal location. There is no obstacles blocking it's path.

Best regards
Kenneth
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

Re: No route found and Invalid goal location

Post by Ken8891 »

Ken8891 wrote: Friday 30 June, 2017 - 08:25 Hi, I have manage to locate which agent. But I don't understand why it is an invalid goal location. There is no obstacles blocking it's path.

Best regards
Kenneth
Attachments
IMG_20170630_142421.jpg
IMG_20170630_142421.jpg (1.06 MiB) Viewed 3425 times
Bram de Vries
Posts: 60
Joined: Thursday 08 January, 2015 - 13:29

Re: No route found and Invalid goal location

Post by Bram de Vries »

Hi Kenneth,

In your screenshot I do not see any strange things. Please upload your model if possible, then I can take a closer look.

Kind regards,

Bram
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

Re: No route found and Invalid goal location

Post by Ken8891 »

Hi Bram,

I could not upload the file due to it being confidential. But I have found out why there is an invalid goal location. As you can see from the picture, I have make a walkable area to the stands. In order for the stands and the walkable area to be connected, I use transfer connection between two height layers. After all this, I check the ECM network, the agent could not reach the center seat(red circle) in the stand as there is no path. Is there any solution to it?
Attachments
IMG_20170630_181528.jpg
IMG_20170630_181528.jpg (1.01 MiB) Viewed 3417 times
Bram de Vries
Posts: 60
Joined: Thursday 08 January, 2015 - 13:29

Re: No route found and Invalid goal location

Post by Bram de Vries »

Hi Kenneth,

I would try to make the Transfer Connection as small as possible. For instance, I just make a connection like the one in the attachment.

Kind regards,

Bram
Attachments
Capture.PNG
Capture.PNG (6.16 KiB) Viewed 3415 times
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

Re: No route found and Invalid goal location

Post by Ken8891 »

Hi Bram,

How do I make the transfer connection as small as possible?

Best Regards
Kenneth
Ken8891
Posts: 22
Joined: Thursday 08 December, 2016 - 04:13

Re: No route found and Invalid goal location

Post by Ken8891 »

Hi Bram,

The best I can do is this. I don't seem to be able to have the straight line like yours.
Attachments
14991501645521473434902.jpg
14991501645521473434902.jpg (804.25 KiB) Viewed 3402 times
User avatar
marlies
Posts: 301
Joined: Monday 17 January, 2011 - 09:28

Re: No route found and Invalid goal location

Post by marlies »

Hi,

The network path looks now fine to me, it doesn't necessarily have to be a straight line. The question is: did the change solve your error message or do you still have the same problem?

Regards, Marlies
Post Reply